#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?)|\.\d+)$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"0.2" & @CRLF & _
"1.23" & @CRLF & _
"-12" & @CRLF & _
".234" & @CRLF & _
"00" & @CRLF & _
"0123" & @CRLF & _
"1223332.4434" & @CRLF & _
"02.4232" & @CRLF & _
"-3.343"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")