const regex = /^(-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?)|\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(-?(?:(?=[1-9]|0(?!\\d))\\d+(?:\\.\\d+)?)|\\.\\d+)$', 'gm')
const str = `0
1
0.2
1.23
-12
.234
00
0123
1223332.4434
02.4232
-3.343`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}