re = /^(-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?)|\.\d+)$/m
str = '0
1
0.2
1.23
-12
.234
00
0123
1223332.4434
02.4232
-3.343'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end