import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?(?:(?=[1-9]|0(?!\\d))\\d+(?:\\.\\d+)?)|\\.\\d+)$";
final String string = "0\n"
+ "1\n"
+ "0.2\n"
+ "1.23\n"
+ "-12\n"
+ ".234\n"
+ "00\n"
+ "0123\n"
+ "1223332.4434\n"
+ "02.4232\n"
+ "-3.343";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}