use strict;
my $str = '0
1
0.2
1.23
-12
.234
00
0123
1223332.4434
02.4232
-3.343';
my $regex = qr/^(-?(?:(?=[1-9]|0(?!\d))\d+(?:\.\d+)?)|\.\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}