#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:_X_[CL]|_L?|(?:_X){0,3})$"
Local $sString = "_X_C" & @CRLF & _
"_X_X_X" & @CRLF & _
"_X_C" & @CRLF & _
"_X_L" & @CRLF & _
"_L" & @CRLF & _
"" & @CRLF & _
"_X_X_X" & @CRLF & _
"_X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")