$re = '/^(?:_X_[CL]|_L?|(?:_X){0,3})$/m';
$str = '_X_C
_X_X_X
_X_C
_X_L
_L
_X_X_X
_X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);