const regex = /^(?:_X_[CL]|_L?|(?:_X){0,3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:_X_[CL]|_L?|(?:_X){0,3})$', 'gm')
const str = `_X_C
_X_X_X
_X_C
_X_L
_L
_X_X_X
_X`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}