// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:_X_[CL]|_L?|(?:_X){0,3})$").unwrap();
let string = "_X_C
_X_X_X
_X_C
_X_L
_L
_X_X_X
_X";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}