package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:_X_[CL]|_L?|(?:_X){0,3})$`)
var str = `_X_C
_X_X_X
_X_C
_X_L
_L
_X_X_X
_X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}