using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:_X_[CL]|_L?|(?:_X){0,3})$";
string input = @"_X_C
_X_X_X
_X_C
_X_L
_L
_X_X_X
_X";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}