#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}"
Local $sString = "himanshubajaj@gmail.in.org" & @CRLF & _
"himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234" & @CRLF & _
"himanshu.bajaj@gmail.com.us" & @CRLF & _
"Himanshu_b.bajaj2gmail.com.in"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")