const regex = /[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}', 'gm')
const str = `himanshubajaj@gmail.in.org
himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234
himanshu.bajaj@gmail.com.us
Himanshu_b.bajaj2gmail.com.in`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}