re = /[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}/m
str = 'himanshubajaj@gmail.in.org
himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234
himanshu.bajaj@gmail.com.us
Himanshu_b.bajaj2gmail.com.in'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end