import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}";
final String string = "himanshubajaj@gmail.in.org\n"
+ "himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234\n"
+ "himanshu.bajaj@gmail.com.us\n"
+ "Himanshu_b.bajaj2gmail.com.in";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}