using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}";
string input = @"himanshubajaj@gmail.in.org
himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234
himanshu.bajaj@gmail.com.us
Himanshu_b.bajaj2gmail.com.in";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}