use strict;
my $str = 'himanshubajaj@gmail.in.org
himanshu_bajaj@gmailhjkhkhkjhkj.com.us1234
himanshu.bajaj@gmail.com.us
Himanshu_b.bajaj2gmail.com.in';
my $regex = qr/[A-Za-z._]{3,}@[A-Za-z]{3,}[.]{1}[A-Za-z.]{2,}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}