using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)hipovitaminosis[\s]{0,3}D|d[eé]ficit[\s]{0,3}vitam[ií]na[\s]{0,3}D|deficiencia[\s]{0,3}[\S[\s]{0,3}vitam[ií]na[\s]{0,3}D|d[ée]ficit[\s]{0,3}vit[\s]{0,3}D|deficiencia[\s]{0,3}vit[\s]{0,3}D|vit[\s]{0,3}D[\s]{0,3}<30";
string input = @"hipovitaminosis D
Déficit vitamina D
Vit D <30
deficiencia de vitamina D
deficit vit D
deficiencia vit D
deficiencia vitamina D
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}