const regex = /(?i)hipovitaminosis[\s]{0,3}D|d[eé]ficit[\s]{0,3}vitam[ií]na[\s]{0,3}D|deficiencia[\s]{0,3}[\S[\s]{0,3}vitam[ií]na[\s]{0,3}D|d[ée]ficit[\s]{0,3}vit[\s]{0,3}D|deficiencia[\s]{0,3}vit[\s]{0,3}D|vit[\s]{0,3}D[\s]{0,3}<30/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)hipovitaminosis[\\s]{0,3}D|d[eé]ficit[\\s]{0,3}vitam[ií]na[\\s]{0,3}D|deficiencia[\\s]{0,3}[\\S[\\s]{0,3}vitam[ií]na[\\s]{0,3}D|d[ée]ficit[\\s]{0,3}vit[\\s]{0,3}D|deficiencia[\\s]{0,3}vit[\\s]{0,3}D|vit[\\s]{0,3}D[\\s]{0,3}<30', 'gm')
const str = `hipovitaminosis D
Déficit vitamina D
Vit D <30
deficiencia de vitamina D
deficit vit D
deficiencia vit D
deficiencia vitamina D
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}