import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)hipovitaminosis[\\s]{0,3}D|d[eé]ficit[\\s]{0,3}vitam[ií]na[\\s]{0,3}D|deficiencia[\\s]{0,3}[\\S[\\s]{0,3}vitam[ií]na[\\s]{0,3}D|d[ée]ficit[\\s]{0,3}vit[\\s]{0,3}D|deficiencia[\\s]{0,3}vit[\\s]{0,3}D|vit[\\s]{0,3}D[\\s]{0,3}<30";
final String string = "hipovitaminosis D\n"
+ "Déficit vitamina D\n"
+ "Vit D <30\n"
+ "deficiencia de vitamina D\n"
+ "deficit vit D\n"
+ "deficiencia vit D\n"
+ "deficiencia vitamina D\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}