$re = '/(?i)hipovitaminosis[\s]{0,3}D|d[eé]ficit[\s]{0,3}vitam[ií]na[\s]{0,3}D|deficiencia[\s]{0,3}[\S[\s]{0,3}vitam[ií]na[\s]{0,3}D|d[ée]ficit[\s]{0,3}vit[\s]{0,3}D|deficiencia[\s]{0,3}vit[\s]{0,3}D|vit[\s]{0,3}D[\s]{0,3}<30/m';
$str = 'hipovitaminosis D
Déficit vitamina D
Vit D <30
deficiencia de vitamina D
deficit vit D
deficiencia vit D
deficiencia vitamina D
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);