#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9_ ]*?([0-9]+\/[0-9_ ]+)|[0-9_ ]+"
Local $sString = "0000" & @CRLF & _
"000" & @CRLF & _
"3 1/2" & @CRLF & _
"4 4/5" & @CRLF & _
"000 000/0000" & @CRLF & _
"1 2_3_7" & @CRLF & _
"1 3 327 9 1234/_3 23" & @CRLF & _
"00 /00 <-fails"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")