import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9_ ]*?([0-9]+\\/[0-9_ ]+)|[0-9_ ]+";
final String string = "0000\n"
+ "000\n"
+ "3 1/2\n"
+ "4 4/5\n"
+ "000 000/0000\n"
+ "1 2_3_7\n"
+ "1 3 327 9 1234/_3 23\n"
+ "00 /00 <-fails";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}