using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9_ ]*?([0-9]+\/[0-9_ ]+)|[0-9_ ]+";
string input = @"0000
000
3 1/2
4 4/5
000 000/0000
1 2_3_7
1 3 327 9 1234/_3 23
00 /00 <-fails";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}