const regex = /[0-9_ ]*?([0-9]+\/[0-9_ ]+)|[0-9_ ]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9_ ]*?([0-9]+\\\/[0-9_ ]+)|[0-9_ ]+', 'gm')
const str = `0000
000
3 1/2
4 4/5
000 000/0000
1 2_3_7
1 3 327 9 1234/_3 23
00 /00 <-fails`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}