$re = '/[0-9_ ]*?([0-9]+\/[0-9_ ]+)|[0-9_ ]+/m';
$str = '0000
000
3 1/2
4 4/5
000 000/0000
1 2_3_7
1 3 327 9 1234/_3 23
00 /00 <-fails';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);