package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9_ ]*?([0-9]+\/[0-9_ ]+)|[0-9_ ]+`)
var str = `0000
000
3 1/2
4 4/5
000 000/0000
1 2_3_7
1 3 327 9 1234/_3 23
00 /00 <-fails`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}