#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)"
Local $sString = "Vicente Clark vicente.clark@gmail.com" & @CRLF & _
"Mark van der Zant" & @CRLF & _
"mark.zant@protonmail.com" & @CRLF & _
"Georgy Collins" & @CRLF & _
"georgy.collins@yahoo.com" & @CRLF & _
"Paul Danilsson" & @CRLF & _
"paul.danilsson@live.com"
Local $sSubst = "$1: $2\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)