import Foundation
let pattern = #"(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Vicente Clark vicente.clark@gmail.com
Mark van der Zant
mark.zant@protonmail.com
Georgy Collins
georgy.collins@yahoo.com
Paul Danilsson
paul.danilsson@live.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1: $2\n\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)