use strict;
my $str = 'Vicente Clark vicente.clark@gmail.com
Mark van der Zant
mark.zant@protonmail.com
Georgy Collins
georgy.collins@yahoo.com
Paul Danilsson
paul.danilsson@live.com';
my $regex = qr/(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)/p;
my $subst = '$1: $2\\n\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";