const regex = /(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\r?\\n)(.*?)(?: |\\r?\\n)([^\\s]+?@.*?)(?=\\r?\\n|$)', 'g')
const str = `Vicente Clark vicente.clark@gmail.com
Mark van der Zant
mark.zant@protonmail.com
Georgy Collins
georgy.collins@yahoo.com
Paul Danilsson
paul.danilsson@live.com`;
const subst = `$1: $2\n\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);