$re = '/(?:^|\r?\n)(.*?)(?: |\r?\n)([^\s]+?@.*?)(?=\r?\n|$)/';
$str = 'Vicente Clark vicente.clark@gmail.com
Mark van der Zant
mark.zant@protonmail.com
Georgy Collins
georgy.collins@yahoo.com
Paul Danilsson
paul.danilsson@live.com';
$subst = "$1: $2\n\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;