# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\d{4}-\d{2}-\d{2})/\n/gm;t' <<< "91.240.109.42FrancePrestashop PI block
2021-06-02213.186.52.66FrancePrestaShop
2012-06-29"