re = /(?<=\d{4}-\d{2}-\d{2})/m
str = '91.240.109.42FrancePrestashop PI block
2021-06-02213.186.52.66FrancePrestaShop
2012-06-29'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result