const regex = /(?<=\d{4}-\d{2}-\d{2})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{4}-\\d{2}-\\d{2})', 'gm')
const str = `91.240.109.42FrancePrestashop PI block
2021-06-02213.186.52.66FrancePrestaShop
2012-06-29`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);