#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\d{4}-\d{2}-\d{2})"
Local $sString = "91.240.109.42FrancePrestashop PI block" & @CRLF & _
"2021-06-02213.186.52.66FrancePrestaShop" & @CRLF & _
"2012-06-29"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)