import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d{4}-\\d{2}-\\d{2})";
final String string = "91.240.109.42FrancePrestashop PI block\n"
+ "2021-06-02213.186.52.66FrancePrestaShop\n"
+ "2012-06-29";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}