# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\d{4}-\d{2}-\d{2})"
test_str = ("91.240.109.42FrancePrestashop PI block\n"
"2021-06-02213.186.52.66FrancePrestaShop\n"
"2012-06-29")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.