#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)"
Local $sString = "<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>" & @CRLF & _
"zsdasd" & @CRLF & _
"<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>" & @CRLF & _
"k;l;" & @CRLF & _
"" & @CRLF & _
"<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe>teste</iframe>" & @CRLF & _
"" & @CRLF & _
"<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe>teste</iframe>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")