$re = '/(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)/';
$str = '<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
zsdasd
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
k;l;
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
<iframe>teste</iframe>
<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe>teste</iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);