// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)").unwrap();
let string = "<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ipuU0hHYiF4\" frameborder=\"0\" gesture=\"media\" allow=\"encrypted-media\" allowfullscreen></iframe>
zsdasd
<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ipuU0hHYiF4\" frameborder=\"0\" gesture=\"media\" allow=\"encrypted-media\" allowfullscreen></iframe>
k;l;
<iframe width=\"560\" height=\"315\" src=\"https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0\" frameborder=\"0\" gesture=\"media\" allow=\"encrypted-media\" allowfullscreen></iframe>
<iframe>teste</iframe>
<iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0\" frameborder=\"0\" gesture=\"media\" allow=\"encrypted-media\" allowfullscreen></iframe><iframe width=\"560\" height=\"315\" src=\"https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0\" frameborder=\"0\" gesture=\"media\" allow=\"encrypted-media\" allowfullscreen></iframe><iframe>teste</iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}