const regex = /(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<iframe.*?(?:www\\.)?(?:youtu\\.be|youtube.*?\\.com)\\\/(?:embed\\\/|v\\\/|watch\\?v=|watch\\?.+&v=)?((?:[\\w-]{11})).*?>.*?\\n*?<\\\/iframe>)', 'g')
const str = `<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
zsdasd
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
k;l;
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
<iframe>teste</iframe>
<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe>teste</iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}