import Foundation
let pattern = #"(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
zsdasd
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
k;l;
<iframe width="560" height="315" src="https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe>
<iframe>teste</iframe>
<iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0" frameborder="0" gesture="media" allow="encrypted-media" allowfullscreen></iframe><iframe>teste</iframe>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)