using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<iframe.*?(?:www\.)?(?:youtu\.be|youtube.*?\.com)\/(?:embed\/|v\/|watch\?v=|watch\?.+&v=)?((?:[\w-]{11})).*?>.*?\n*?<\/iframe>)";
string input = @"<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/ipuU0hHYiF4"" frameborder=""0"" gesture=""media"" allow=""encrypted-media"" allowfullscreen></iframe>
zsdasd
<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/ipuU0hHYiF4"" frameborder=""0"" gesture=""media"" allow=""encrypted-media"" allowfullscreen></iframe>
k;l;
<iframe width=""560"" height=""315"" src=""https://www.youtube.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0"" frameborder=""0"" gesture=""media"" allow=""encrypted-media"" allowfullscreen></iframe>
<iframe>teste</iframe>
<iframe width=""560"" height=""315"" src=""https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0"" frameborder=""0"" gesture=""media"" allow=""encrypted-media"" allowfullscreen></iframe><iframe width=""560"" height=""315"" src=""https://www.youtube-nocookie.com/embed/ipuU0hHYiF4?rel=0&controls=0&showinfo=0"" frameborder=""0"" gesture=""media"" allow=""encrypted-media"" allowfullscreen></iframe><iframe>teste</iframe>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}