#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([а-яё]+\s+\d+)"
Local $sString = "1234123434" & @CRLF & _
"Ленина 48" & @CRLF & _
"Ленина 39Б" & @CRLF & _
"2-й Турундаевский пер. 44б" & @CRLF & _
"Турундаевский переулок 12" & @CRLF & _
"zzzzzzzz" & @CRLF & _
"z 45" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")