$re = '/([а-яё]+\s+\d+)/i';
$str = '1234123434
Ленина 48
Ленина 39Б
2-й Турундаевский пер. 44б
Турундаевский переулок 12
zzzzzzzz
z 45
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);