package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([а-яё]+\s+\d+)`)
var str = `1234123434
Ленина 48
Ленина 39Б
2-й Турундаевский пер. 44б
Турундаевский переуло к 12
zzzzzzzz
z 45
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}