import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([а-яё]+\\s+\\d+)";
final String string = "1234123434\n"
+ "Ленина 48\n"
+ "Ленина 39Б\n"
+ "2-й Турундаевский пер. 44б\n"
+ "Турундаевский переулок 12\n"
+ "zzzzzzzz\n"
+ "z 45\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}