re = /([а-яё]+\s+\d+)/i
str = '1234123434
Ленина 48
Ленина 39Б
2-й Турундаевский пер. 44б
Турундаевский переулок 12
zzzzzzzz
z 45
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end