// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([а-яё]+\s+\d+)").unwrap();
let string = "1234123434
Ленина 48
Ленина 39Б
2-й Турундаевск ий пер. 44б
Турундаевский переулок 12
zzzzzzzz
z 45
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}